Computer networks, new technology, CMS, and more; is the main focus of this website.
Tuesday, November 4, 2014
LNS LAC sample configuration
This time we have a sample configuration about LNS - LAC, mostly used for DSL provider to transfer pppoe traffic. We use cisco 2811 for this scenario:
LNS configuration :
Building configuration...
Current configuration : 1309 bytes
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lns
!
boot-start-marker
boot-end-marker
!
!
aaa new-model
!
!
aaa authentication ppp default local
!
aaa session-id common
!
resource policy
!
!
!
ip cef
!
!
vpdn enable
!
vpdn-group adsl1
! Default L2TP VPDN group
accept-dialin
protocol l2tp
virtual-template 2
local name vahid
relay pppoe bba-group test1
!
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username cisco password 0 cisco
username saeed password 0 saeed
!
!
!
!
!
!
bba-group pppoe test1
virtual-template 2
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
pppoe enable group test
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Virtual-Template2
ip unnumbered Loopback0
peer default ip address pool pppoe
ppp authentication chap pap
!
ip local pool pppoe 100.0.0.1 100.0.0.10
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
!
scheduler allocate 20000 1000
!
end
lns#
here is LAC configuration:
Building configuration...
Current configuration : 1290 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lac
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
!
subscriber profile sam
service relay pppoe vpdn group adsl
!
vpdn enable
vpdn source-ip 192.168.10.2
!
vpdn-group adsl
request-dialin
protocol l2tp
initiate-to ip 192.168.10.1
local name vahid
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username saeed password 0 saeed
!
!
!
!
!
!
bba-group pppoe test
virtual-template 1
service profile sam
!
!
interface Loopback0
ip address 10.10.10.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group test
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface Virtual-Template1
ip unnumbered Loopback0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
lac#
Labels:
adsl,
configuration,
l2tp,
lac,
lns,
network,
ppp,
pppoe,
tunnel,
unnumbered
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment